Requisitos Stack Tenológico Magento 2.4

Para tener un sitio a salvo de ataques externos, es fundamental mantenerlo siempre actualizado. Cuando se trata de E-Commerce, esta operación se convierte en una rutina fundamental a seguir, con el fin de proteger a sus clientes.

Últimamente Magento ha lanzado la versión Magento 2.4 junto con sus parches relacionados.

La última versión disponible incluye toneladas de nuevas funciones y correcciones de errores (bug fix), con múltiples cambios de seguridad, 7 ciclos de test, 12 paquetes y extensiones, así como soporte para Php 7.4

Pero, ¿cuáles son los requisitos del stack tecnológico de esta nueva versión de Magento? Veámoslos juntos.

Requisitos tecnológicos de Magento 2.4

La siguiente tabla muestra las versiones de software que se probaron y admitieron oficialmente en el momento del lanzamiento de la versión de Magento. Es posible que las versiones más recientes del software requerido funcionen, pero no se han probado.

requisiti-sistema-magento2

Varios

Esta sección describe el soporte y la compatibilidad para todos los demás tipos de software requeridos y opcionales.

Server email

Mail Transfer Agent (MTA) o un server SMTP

Sistemas operativos (Linux x86-64)

Distribuciones Linux, como RedHat Enterprise Linux (RHEL), CentOS, Ubuntu, Debian y similares. Magento no es compatible con Microsoft Windows y macOS.

Extensiones PHP

  • ext-bcmath
  • ext-ctype
  • ext-curl
  • ext-dom
  • ext-gd
  • ext-hash
  • ext-iconv
  • ext-intl
  • ext-mbstring
  • ext-openssl
  • ext-pdo_mysql
  • ext-simplexml
  • ext-soap
  • ext-xsl
  • ext-zip
  • ext-sockets

Para obtener detalles sobre la instalación, puede consultar la documentación oficial de PHP

PHP OPcache

Siempre debe verificar que PHP OPcache esté habilitado por razones de rendimiento. OPcache está habilitado en muchas distribuciones PHP. Para comprobar si está instalado, consulte la documentación PHP de Magento .

Si necesita instalarlo por separado, consulte la documentación de PHP OPcache .

Configuración PHP

Debe usar ajustes de configuración especiales de PHP, como memory_limit , que pueden evitar problemas comunes al usar Magento.

Para obtener más información, consulte Configuración de PHP requerida .

PHPUnit

PHPUnit (como herramienta de línea de comandos) 9.0.0

RAM

La actualización de las aplicaciones y extensiones de Magento obtenidas de Magento Marketplace y otras fuentes puede requerir hasta 2 GB de RAM. Si está utilizando un sistema con menos de 2 GB de RAM, le recomendamos que cree un archivo de intercambio ; de lo contrario, la actualización puede fallar.

Dependencias del sistema

Magento requiere las siguientes herramientas del sistema para algunas de sus operaciones:

SSL

  • Se requiere un certificado de seguridad válido para HTTPS.
  • Los certificados SSL autofirmados no son compatibles.
  • Requerido Transport Layer Security (TLS): PayPal y repo.magento.com requieren TLS 1.2 o posterior.

Navegadores compatibles

Storefront y Admin:

  • Microsoft Edge, más reciente –1
  • Firefox más reciente, más reciente-1 (cualquier SO)
  • Chrome más reciente, más reciente-1 (cualquier SO)
  • Safari más reciente, más reciente-1 (solo Mac OS)
  • Safari Mobile para iPad 2, iPad Mini, iPad con display Retina (iOS 12 o siguientes), para Storefront desktop
  • Safari Mobile para iPhone 6 o sucesivos; iOS 12 o versiones posteriores, para el escaparate mobile
  • Chrome para dispositivos móviles más reciente–1 (Android 4 o versiones posteriores) para el escaparate mobile

Xdebug

php_xdebug 2.5.x  o posterior (solo entornos de desarrollo; puede tener un efecto negativo en el rendimiento).

Existe un problema conocido con xdebug que puede afectar a las instalaciones de Magento o el acceso al storefront o al administrador de Magento después de la instalación. Para obtener más detalles, puede ver la información en la guía de Magento .

Deja una respuesta

Tu dirección de correo electrónico no será publicada.